14 comments on “How to add new exploits to Metasploit from exploit-db

    • @Mario, give space between ‘cd’ and ‘/root/.msf4/’. Remember Linux is very strict.

  1. I have the following errors any idea:
    from /usr/share/metasploit-framework/modules/exploits/windows/local/40085.rb) due to Missing compatible Metasploit class constant

  2. Hi. I googled importing of exploits from exploit-db to MSF. But all examples are ruby scripts. I tried to import python .py scripts, then i performed Search on MSF prompt but the added .py exploit did not appear in the Search results. I tried both (1)/root/msf4/modules and (2) /usr/share/metasploit-framework/modules/. Both without success. How do we import python scripts from exploit-db into metasploit?

    • Hello Marko, Metasploit is entirely coded in Ruby and at present it only supports Ruby exploits.It doesn’t support modules or scripts written in Python. This is the reason why python exploits do not appear in Metasploit search results.

Leave a Reply

Your email address will not be published. Required fields are marked *